安装 Joomla! 遇到的关于 MySQL 密码验证的问题

这两天我在尝试选择一个 CMS 系统,看过了网上的不少文章,在 CMS Matrix 站点上做了 N 次的对比表之后,决定采用 Joomla!。安装的时候,着实费了一点时间。
Joomla! 的官方安装文档倒是图文并茂的,但是还有些简略。第二步的时候,需要输入数据库的信息,主机名字,用户名,密码,还有数据库名字,可是总无情的弹出一个窗口告诉我 “Password and username incorrect…”。在终端命令行下,通过这些信息是可以登陆的。
RHEL 3 自带的 MySQL 版本比较低(3.23.58),启动比较麻烦,干脆跑到 MySQL 官方站点下载了一个 5.0 的稳定版本来用。
难道是版本太高带来的问题么 ?
尝试搜索了一下,原来是老问题

A.2.3. Client does not support authentication protocol
MySQL 4.1 and up uses an authentication protocol based on a password hashing algorithm that is incompatible with that used by older clients. If you upgrade the server to 4.1, attempts to connect to it with an older client may fail with the following message:

按照该帖子提示的用 OLD_PASSWORD() 重新设置了一下指定用户的密码,安装可以继续下去了。
登录到后台,测试了几篇帖子,发现 Joomla! 对中文的支持超出我的期待。
EOF


  • http://bemike.org/ Michael

    你不是用dreamhost的吗,可以直接一键安装吧,我装过一点问题也没有。

  • http://www.dbanotes.net Fenng

    我是在自己的 Linux 上安装测试

  • http://dowei.otlog.com dowei

    密码问题貌似是几乎所有安装基于mysql的人都会遇到的问题,而我,在这上面绊倒了两次,十分郁闷。

  • http://www.dbanotes.net Fenng

    安装文档应该加以说明才是

  • http://blog.dbform.com kamus

    Joomla! 对中文的支持不是那么好吧,难道是我没有设置,至少默认对于中文的标题就显示不出来。

  • http://www.dbanotes.net Fenng

    我测试没有遇到这样的情况

  • 吕朋

    Fenng,你好。我想请教你一个比较紧急的问题,在网上搜了很久都没找着答案。
    问题如下:
    在安装 Joomla 1.5 的第二个步骤(2 : 安裝前檢查 )的时候有如下显示 :
    —————————————–
    —————————————–
    PHP版本 >= 4.3.10 是
    – zlib壓縮支援 是
    XML支援 是
    – MySQL支援 否
    configuration.php 可寫入 是
    —————————————–
    —————————————–
    在MySQL 支援这里是 “否” 。
    我的php 版本是 5.2.6 。
    apache 是2.0 。
    在cmd下 可以成功链接上mysql。
    不知道是哪里出现了问题。 请大侠指点,小弟感激不尽。
    希望明天能得到你的回复,谢谢。
    2008-09-20 0:55

  • 吕朋

    Fenng,你好。我想请教你一个比较紧急的问题,在网上搜了很久都没找着答案。
    问题如下:
    在安装 Joomla 1.5 的第二个步骤(2 : 安裝前檢查 )的时候有如下显示 :
    —————————————–
    —————————————–
    PHP版本 >= 4.3.10 是
    – zlib壓縮支援 是
    XML支援 是
    – MySQL支援 否
    configuration.php 可寫入 是
    —————————————–
    —————————————–
    在MySQL 支援这里是 “否” 。
    我的php 版本是 5.2.6 。
    apache 是2.0 。
    在cmd下 可以成功链接上mysql。
    不知道是哪里出现了问题。 请大侠指点,小弟感激不尽。
    希望明天能得到你的回复,谢谢。
    2008-09-20 0:55

  • Fenng

    @吕朋
    信息似乎不是很足够,你的 MySQL 是怎么安装的?
    BTW: 也可能是环境变量达到问题